Discover Card issues on First Data Platforms
Incident Report for BridgePay Network Solutions
Resolved
This incident has been resolved.
Posted Oct 13, 2017 - 12:15 EDT
Identified
BridgePay Network Operations team has confirmed with FirstData that there is an issue on their end processing Discover cards on the FirstData North and Nashville platforms. At this time there is no ETA for resolution. We will continue to provide updates we receive from FirstData on this incident via our Status page. Please note, no other card types are effected, and all BridgePay services are processing.
Posted Oct 13, 2017 - 09:53 EDT