Phone System Issues
Incident Report for BridgePay Network Solutions
Resolved
This incident has been resolved.
Posted Dec 04, 2019 - 14:18 EST
Investigating
Please note, BridgePay Network Solutions is currently experiencing issues with our phone system. All calls to our 24/7 Support Number - 866-322-9894 are working. We will update here once this issue is resolved.
Posted Dec 04, 2019 - 09:56 EST