Unable To reach Host error eCard Systems.

Incident Report for BridgePay Network Solutions

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 22:32 EDT

Identified

We are waiting on eCard to give us all clear.
Posted Aug 04, 2025 - 17:07 EDT
This incident affected: Gift Card Processors (eCard).