Integra Pay Service Disruption
Incident Report for BridgePay Network Solutions
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 06:24 EDT
Investigating
We are currently investigating this issue.
Posted Jun 21, 2022 - 03:19 EDT
This incident affected: Credit Card Processors (IntegraPay).