Phone System Issues
Incident Report for BridgePay Network Solutions
Resolved
This incident has been resolved.
Posted Oct 15, 2024 - 09:07 EDT
Monitoring
We are starting to see calls come through and continue to monitor
Posted Oct 14, 2024 - 19:23 EDT
Identified
Our service provider is currently experiencing issues, causing interruptions in customers reaching our support by phone. If you need to contact support please reach out to Gateway.Support@bridgepaynetwork.com. We will update this status with any changes.
Posted Oct 14, 2024 - 13:07 EDT
This incident affected: BridgePay Support (BridgePay Phone Support).