Profit Stars-Check Service- Degraded Performance
Incident Report for BridgePay Network Solutions
Resolved
This incident has been resolved.
Posted Jan 21, 2024 - 02:07 EST
Investigating
We are currently investigating this issue.
Posted Jan 21, 2024 - 01:59 EST
This incident affected: Check Processors (ProfitStars).