Discover Cards on TSYS
Incident Report for BridgePay Network Solutions
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 18, 2019 - 12:17 EDT
Identified
We are currently aware of an issue with Discover/JCB cards not processing on the TSYS platform and are investigating with TSYS. Please note the gateway is fully operational and this issue is isolated to customers on processing on the TSYS platform.
Posted 3 months ago. Jun 18, 2019 - 10:56 EDT
This incident affected: Credit Card Processors (TSYS).